rmml.net
当前位置:首页 >> jAvA 1.7和1.6 环境变量切换 >>

jAvA 1.7和1.6 环境变量切换

没办法两个jdk都配置的,但是可以两个都安装上,之后配置一个默认环境变量,之后根据实际需要来进行jkd切换。 java7的话,直接默认进行安装即可,之后配置环境变量。 如:jdk安装在“D:\Program Files\jdk1.7.0_10” 第一步:新建“java_home”值,...

不一样的。每个jdk都要配置自己的环境变量。 配置环境变量:右击“我的电脑”-->"高级"-->"环境变量" 1)在系统变量里新建JAVA_HOME变量,变量值为:C:\Program Files\Java\jdk1.7.0_20(根据自己的安装路径填写) 2)新建classpath变量,变量值为...

要用哪个,就设置那个的JAVA_HOME和PATH。。。。。。。。。。注意 system32下有java*.exe ,如果是高版本的,设置低版本的JAVA_HOME时,运行会报错。

C:\windows\System32下,还有java.exe。。。 所以,要将 JAVA的bin目录,放在PATH的最前面。。。。。。。。。。。。

1)在系统变量里新建JAVA_HOME变量,变量值为:C:\Program Files\Java\jdk1.7.0_06 2)新建classpath变量,变量值为:.;%JAVA_HOME%\lib;%JAVA_HOME%\jre\lib 3)在path变量(已存在不用新建)添加变量值(重点:在最前面添加):%JAVA_HOME%\bi...

要么就是你JDK 安装有问题, 要么就是你的环境变量配置有问题。 需要看你电脑上的情况了。

要用哪个,就设置那个的JAVA_HOME和PATH。。。。。。。。。。注意 system32下有java*.exe ,如果是高版本的,设置低版本的JAVA_HOME时,运行会报错。

如果是某些软件依赖的版本,那么不建议卸载,如netbeans7.0用的是jdk1.7,eclipse用的是1.6,我的世界游戏用的是1.6版本,那么肯定是不能卸载的。 如果确认电脑中可以通用一个版本,那么可以卸载一个,保留一个,之后重新配置下此版本的环境变量...

查看你的环境变量中Path的配置,确认%java_home%/bin在path值的第一个。 或者在cmd中输入echo %path%,看一下实际有效的path值是什么,其中的java配置对不对。

因为1.7是 64位的,所以报错: [2014-06-21 22:38:49] [206 javajni.c] [error] %1 不是有效的 Win32 应用程序。 [2014-06-21 22:38:49] [985 prunsrv.c] [error] Failed creating java D:\jdk1.7\jre\bin\server\jvm.dll [2014-06-21 22:38:49]...

网站首页 | 网站地图
All rights reserved Powered by www.rmml.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com